Sidebar and Content Analyzer 2019 Not Working: Error: Content too large
Issue
When you check a document, Acrolinx Sidebar shows error message:
Content too large, Content exceeds 1024000 characters.
Content Analyzer Error Message:
Something went wrong but we couldn't identify the cause.
Check the log file for any errors.
Content Analyzer Logs:
2019-10-04 10:25:17,294 | info | Got check result for file C:\Users\Team\DOCUMENT_NAME.doc 2019-10-04 10:25:17,294 | warn | Check finished with errors. 2019-10-04 10:25:17,294 | warn | Error: Content to large
Environment
Product | Version |
---|---|
Acrolinx Core Platform Any Sidebar, Automated Check, or other integration that uses the Platform checking API | 2019.04 and later Any and all versions of integrations |
Cause
In Acrolinx Platform 2019.04, we added a limit to how large a single check request can be. This improvement was intended to make checking large amounts of content more robust.
Solution
This limit depends on the Java Virtual Machine Memory allocation of the language server.
Adjust the JVM memory allocation of the language server, this is detailed in our document portal, here.
Related articles