Language servers aren't connecting to Core Server

Issue

I can't see my language servers in the Dashboard. And in the corresponding language server log I see following entry again and again.

ls-01.log
2019/06/20 10:36:21.766 | [WARN ][connector] Unable to report status to core server at http://localhost:8031/internal

Environment

I’ve updated our Acrolinx environment according to the manual from a version lower than 5.4 to a version higher than 5.4

Solution

Update your ls-<NUMBER>.properties files located in your configuration directory.


To Update Your ls-<NUMBER>.properties Files

  1. Shut down your Core Platform
  2. Navigate to the appropriate configuration directory for your operating system (see infobox below).

    On a Windows installation the ls-<NUMBER>.properties files are here:

    C:\ProgramData\Acrolinx\ServerConfiguration\server\bin

    On a UNIX installation they’re found in:

    <USER_HOME>/.config/Acrolinx/ServerConfiguration<VERSION_NUMBER>/server/bin
  3. Identify the properties files of your language server.

    On a standard installation you should have 2 (ls-01.properties, ls-02.properties). You may have more depending on your configuration.
  4. Edit each file to make sure that the localhost port number is 8032

    ## core server endpoint address
    coreServerEndpointUrl=http://localhost:8032/internal
  5.  Restart your Core Platform


If this doesn't help, or if you have any further issues after updating to Acrolinx Core Platform V5.4 or later, contact Acrolinx Support.

Cause

For improvements to security, the Acrolinx core server V5.4 and later uses Port 8032 for internal communication and no longer Port 8031.